Conception d’un modèle compatible Métopes
Définition du modèle
Un modèle est un document InDesign dans lequel on n’a jamais importé de fichier XML, et contenant:
- trois pages avec un bloc de texte principal sur chacune, les trois blocs étant chaînés ;
- une collection de styles de paragraphe ;
- une collection de styles de caractère ;
- un paramétrage des notes.
Prérequis
Avant de créer un modèle, il faut avoir à disposition au moins une unité éditoriale stylée au moyen de la feuille de style Métopes, puis convertie en XML par le biais d’XMLmind. Ce fichier doit être valide, et placé dans le dossierXML.
N.B. : Il peut y avoir plusieurs modèles pour un volume, si toutes les UE n’ont pas les mêmes caractéristiques graphiques.
Création du document
Pour créer un modèle, il faut créer un nouveau document InDesign de trois pages aux dimensions et marges personnalisées. Les options Pages en vis-à-vis et Bloc de texte principal doivent être cochées.

Un document se crée, où les blocs de texte sont liés. Pour le vérifier, aller dans Affichage > Extras > Afficher le chaînage du texte : un chaînage bleu apparaît.

Le document est à enregistrer au format .indd dans le dossier INDD, sous un nom respectant les règles de nommage définies dans la partie éponyme.
Création, personnalisation, et import des styles
Chaque style Word correspond à un ou plusieurs style(s) InDesign, selon son contexte d’apparition (voir le tableau de correspondance). Ces styles de caractère et de paragraphe sont à déterminer dans le modèle, qui pour l’instant n’en contient aucun : les fenêtres accessibles depuis Affichage > Styles > Styles de paragraphe sont vides.
La méthode recommandée consiste à générer automatiquement les styles Métopes à partir d’une unité éditoriale, à personnaliser leurs caractéristiques graphiques dans cette unité, puis à les importer dans le modèle. Il est déconseillé de créer les styles à la main directement dans le modèle pour éviter les erreurs de nommage.
Création des styles
Cette étape consiste à générer les styles en important dans InDesign un chapitre ou article type par le biais du modèle précedemment créé. Pour cela :
- fermer le modèle ;
- dans InDesign, aller dans
Fenêtre>Utilitaires>Scripts>Utilisateur>metopes>Import_UE.jsx;
- renseigner dans le premier champ l’unité éditoriale à importer, au format .xml, de préférence avec le plus de styles Word différents possibles ;
- renseigner dans le second champ le modèle InDesign ;
- cliquer sur “Appliquer”.
Un document .indd correspondant à l’unité éditoriale est alors généré, avec des styles de caractère et de paragraphe nommés selon les normes Métopes.

Personnalisation des styles
Les styles sont maintenant créés, mais n’ont pas de caractéristiques graphiques propres. Pour paramétrer les styles de paragraphe, d’abord, la marche à suivre est la suivante :
- ouvrir la fenêtre des styles si c’est n’est pas déjà fait :
Affichage>Styles>Styles de paragraphe; - cliquer sur un paragraphe du texte : le style associé est surligné en bleu dans la liste de styles ;
- clic droit sur le style, puis
Modifier “Nom du style…”; - paramétrer le style à l’aide des différents onglets ;
- recommencer l’opération pour chaque paragraphe, jusqu’à ce que tous les styles soient définis.

Pour les styles de caractère, plus particulièrement :
- cliquer sur la flèche noire, dans le menu ci-dessous ;

- clic droit sur le style à paramétrer dans la fenêtre des styles de caractère, puis
Modifier “Nom du style…”; - dans l’onglet
Formats de caractères de base, paramétrer le style de police, la casse et/ou la position selon le style sélectionné.
Attention
Le style [typo_Italique] ne doit pas être déterminé car c’est un style à bascule, c’est-à-dire qu’il varie en fonction du contexte : dans un paragraphe en italique, le mot italique bascule en romain.

Import des styles
Une fois que tous les styles ont été définis, il faut les importer dans le modèle. Pour cela :
- ouvrir le modèle .indd ;
- dans la fenêtre des styles de paragraphe, cliquer sur le menu en haut à droite ;

- cliquer sur
Charger tous les styles de texte…; - sélectionner le document .indd où les styles ont été définis et faire
Ouvrir; - cliquer sur
Tout sélectionner, puis surOK;
Le modèle contient maintenant les styles que l’on avait définis dans l’unité éditoriale choisie au départ. Il n’est toutefois pas encore complet car cette dernière ne contenait peut-être pas tous les styles que pourraient contenir de futurs chapitres ou articles, comme des figures avec titres et légendes, ou encore des citations. Pour compléter le modèle, il est nécessaire de réitérer l’opération à partir de l’étape “Création des styles”, avec une unité éditoriale plus complète. Cette démarche peut être réalisée au fur et à mesure du travail sur un volume : chaque chapitre ou article apportera de nouveaux styles, à personnaliser puis à importer dans le modèle.
Paramétrage des notes
Pour les notes de bas de page, en plus de personnaliser le style txt_Note lors de l’étape “Personnalisation des styles”, un second niveau de paramétrage est à opérer directement dans le modèle :
- dans
Texte>Option de note de bas de page du document…; - puis dans l’onglet
Numérotation et mise en forme; - associer les notes du document au style de paragraphe
txt_Note.

L’onglet Mise en page permet ensuite, de manière facultative, de paramétrer l’espacement entre les notes, la présence ou non d’un filet, ou encore le fractionnement ou non des notes.
Ces options sont à configurer directement dans le modèle car, contrairement aux styles, on ne peut pas les importer depuis un autre document.
Point de vigilance
Il serait tenant de créer un modèle à partir d’un article ou d’un chapitre où tous les styles, notes et gabarits seraient déjà définis, et dont on aurait supprimé le contenu pour ne conserver que trois pages vides. Toutefois, des vestiges de l’ancien fichier XML y seraient conservés et créeraient des conflits lors de l’import d’un nouveau fichier. Par exemple, des parties de l’ancien document pouraient apparaître au hasard dans le nouveau.
Pour vérifier que la structure du modèle est vide, aller dans Affichage > Structure > Afficher la structure. Seul un élément Root doit apparaître.

Après avoir défini le modèle et avant de commencer tout travail de mise en page, il est recommandé d’en faire une copie à conserver dans un dossier à part.